IN-8003 kein mqtt Alarm

Hallo, ich habe eine 9008 und neuerdings eine 8003 laufen, die 9008 meldet über mqtt Alarmeldungen. Die 8003er meldet lediglich Status-Meldungen jedoch keine Alarmtrigger.
Ich habe bei beiden Kameras die Einstellungen überprüft, konnte keine Unterschiede (außer MAC) feststellen. Die 8003 wurde auch komplett zurück gesetzt und neu Konfiguriert, leider kommen keine Alarme an! Der mqtt-Server wurde extern als auch von der Kamera benutzt alle Ergebnisse waren gleich, Statusmeldungen z.B. IR-LED ein und ausschalten kamen an aber keine Alarmmeldung.
Hat jemand eine Idee?

Hallo,
sind denn Alarmbereiche in der 8003 definiert? Was steht denn im Log der Kamera? Wenn es Alarme gegeben haben müsste, die aber nicht per MQTT signalisiert wurden, dann müssten diese zumindest protokolliert worden sein.
Grüße

Hallo,
die Alarmbereiche sind definiert, der Alarm wird auch protokolliert die Videos auch auf der SD Karte gespeichert, ich kann auch die Kamera mit mqtt ansprechen z.B. Audioalarm ein/aus schalten. Alarm-Meldungen laufen aber nicht auf.

Gibt die 8003 den Alarm als eigenen Topic aus, der auch im Broker so subscribed ist? Vielleicht geht ja was schief, wenn beide Kamera denselben Topic versenden, den der Broker aber nur bei der 9008 akzeptiert.

Steht im Log der 8003, dass eine Alarmmeldung abgeschickt wurde? Oder hast Du bisher nur auf der Empfangsseite nachgesehen?

Hallo, hier ein Auszug aus der Logbuch der 8003
[2021/03/17 12:39:20] Event: Audioalarm wurde ausgelöst
[2021/03/17 12:39:22] Event: Audioalarm wurde ausgelöst
[2021/03/17 12:39:24] Video auf SD
[2021/03/17 12:39:24] Event: Audioalarm wurde ausgelöst
[2021/03/17 12:39:26] Event: Audioalarm wurde ausgelöst
[2021/03/17 12:39:28] Event: Audioalarm wurde ausgelöst
[2021/03/17 12:39:30] Event: Audioalarm wurde ausgelöst
[2021/03/17 12:39:32] Event: Audioalarm wurde ausgelöst
[2021/03/17 12:39:34] Event: Audioalarm wurde ausgelöst
Bei der 9008er ist im Logbuch noch der Eintrag das der MQTT-Broker Kontaktiert wurde. Ich habe den Eindruck das das Event nicht gesendet wird!
Die Topics habe ich bei den Kameras schon im 1. Versuch geändert, auch die 8003 habe ich auf Werkseinstellungen zurück gesetzt, hat aber nichts gebracht.

Der Haken bei „Alarmserver kontaktieren“ ist doch wohl gesetzt, ebenso wie „MQTT aktivieren“?

Ich habe keinen Alarmserver eingerichtet, hatte aber auch hier einiges Erfolglos versucht. MQTT ist aktiviert es kommen Status Meldungen am Broker an. Benötige ich einen Alarmserver? Die 9008 schickt die Meldungen ohne den Server.

Nicht zwingend. Die Meldung an einen internen/externen Broker sollte erst mal reichen.
Vielleicht hilft es bereits, MQTT auf der Kamera zu deaktivieren, dann die Kamera neu starten und anschliessend MQTT wieder zu aktivieren. Evtl. wieder mit Neustart.
Ist eigentlich die Authentifizierung abgeschaltet? Ansonsten müsste der Broker das Zertifikat der Kamera noch bekommen, damit die Verbindung mit Authentifizierung funktioniert.

Hallo,
die Authentifizierung ist bei den Cams sowie beim Broker ausgeschaltet. Die Versuche den eigenen MQTT der Kamera zu verwenden war leider so wenig zielführend wie ein Werksreset mit erneuter manueller Einrichtung.
Lediglich Statusmeldungen wie IR-LED auto/close kommen am Broker an aber keine Alarme!

Hallo @Gartenzwerg,

wie ist der MQTT Alarmserver denn konfiguriert? Der Server der da verwendet wird ist der vierte Alarmserver (Index[4]):

/param.cgi?cmd=getmdalarm&-aname=server3

Hier sollte drinnen stehen das der Dienst aktiviert ist und das Intervall auf 1s steht:

var md_server3_switch="on";
var md_server3_interval="1";

Und hier kann man die Konfiguration sehen:

/param.cgi?cmd=getalarmserverattr&-as_index=4

as_server[3]="127.0.0.1";
as_port[3]="80";
as_auth[3]="1";
as_username[3]="admin";
as_password[3]="instar";
as_path[3]="/param.cgi";
as_area[3]="1";
as_io[3]="1";
as_audio[3]="1";
as_areaio[3]="1";
as_activequery[3]="1";
as_query1[3]="1";
as_queryattr1[3]="cmd";
as_queryval1[3]="setobjattr";
as_query2[3]="0";
as_queryattr2[3]="";
as_queryval2[3]="";
as_query3[3]="0";
as_queryattr3[3]="";
as_queryval3[3]="";
as_query4[3]="0";
as_queryattr4[3]="";
as_queryval4[3]="";
as_query5[3]="0";
as_queryattr5[3]="";
as_queryval5[3]="";
as_ex[3]="0";
as_img[3]="0";
as_ssl[3]="0";
as_mode[3]="0";

In Worten - bei Alarm sende den setobjattr CGI Befehl an localhost und Authentifiziere dich mit dem Admin Login der Kamera.

Eventuell hat es da irgendwo die Konfig zerfetzt?

Hallo @m.polinowski,
danke für den Hinweis, die Konfiguration sieht bei mir genauso aus.
Ich habe aus der Konifguration gesehen das der Port 80 vom Alarmserver benötigt wird, in den Netzwerkeinstellungen habe ich einen anderen Port angegeben. Den habe ich jetzt auf 80 gesetzt nun bekomme ich die Alarme.
Kann ich den Port des Alarmserver anpassen und meinen gewünschten Port verwenden?

Hallo,

welcher Port war das jetzt der geändert wurde? In der IP Config der Kamera?

Oder der as_port[3]="80"; ?

Hallo,
as_port[3]=„80“; wurde unter „/param.cgi?cmd=getalarmserverattr&-as_index=4“ angezeigt. Im Setup der Kamera habe ich bei Netzwerkeinstellungen den Port auf 80 zurück gesetzt und so kommen Alarme an.

Dann mal den as_port[3] per CGI Befehl auf den Port ändern, den man auch in den Netzwerkeinstellungen verwendet (wenn != 80) - dann sollte es funktionieren:

Eigentlich sollte das automatisch geschehen - wir schauen es uns einmal an.

Hallo,
ich habe versucht den Port mit dem CGI-Befehl
/param.cgi?cmd=setalarmserverattr&-as_index=4&-as_port[3]=xxxx
umzustellen. Laut Meldung „[Succeed]set ok.“
Sehe ich dann nach /param.cgi?cmd=getalarmserverattr&-as_index=4 steht der Port 80 drin!
Um es vorweg zu nehmen. Die Kamera wurde nach der Umstellung neu gestartet.

Das ist der Befehl um alles zu resetten - da einfach das Port 80 gegen den gewünschten Port austauschen:

/param.cgi?cmd=setmdalarm&-aname=server3&-switch=on&-interval=1&cmd=setalarmserverattr&-as_index=4&-as_server=127.0.0.1&-as_port=80

  1. MQTT Alarmserver: aktiv
  2. Cooldown: 1s
  3. Server: 127.0.0.1 (localhost)
  4. Port: 80 (default)

Hallo,
Danke, jetzt läuft’s wie gewünscht.

1 Like