Firmware Update endet ohne Änderung

Hallo,

Ich habe zwei IN-9008 über LAN in Betrieb und wollte heute beide updaten. Also aktuelles File IN-9008_FW_4.1.2.48_WebUI_3.2.(366)_update.zip geholt, entpackt und das update.pkg installiert.
Bei einer Kamera klappt das problemlos, die „Uhr“ läuft langsam bis ca. 45%, dann schnell bis zu Ende und die neue Firmware ist drauf.
Bei der anderen Kamera läuft die „Uhr“ langsam nur bis ca. 38% und dann schnell zu Ende. Es gibt keine Fehlermeldung, aber die Software ist nach dem Update immer noch die alte. Es liegt auch nicht am Browsercache, in der System-Info wird nach wie vor die alte Version angezeigt.
Ich habe den Versuch ein paarmal wiederholt, immer mit gleichem Ergebnis: das Update läuft anscheinend durch, aber nach Neustart ist immer noch die alte Firmware drauf.

Was mache ich falsch?

Danke
Jean

Hallo,
hast Du die Kamera vor dem Update einmal stromlos gemacht und erst nach dem Neustart das Update versucht?
Grüße

Hallo,

Danke für den Tipp, gestern hatte ich tatsächlich die Kamera nicht vom Strom getrennt. Leider führt stromlos machen vor dem Update auch nicht zum Erfolg.

Das erste merkwürdige Verhalten ist, dass im Browser die installierte FW 4.1.2.43 als aktuell angezeigt wird, wobei 4.1.2.48 aktuell ist. Beim WebUI wird als aktuelle Version „2.3 (366)“ angezeigt, tatsächlich scheint aber „3.2 (366)“ korrekt zu sein.
Ein Klick auf „Update Datei laden“ lädt auch nicht die aktuelle Version, sondern „IN-9008_FW_4.1.2.48_WebUI_3.0.(328)_update“ vom August 2020. Vielleicht ist ein Update von meiner alten Version auf den aktuelle Stand nicht direkt möglich, aber auch ein Updateversuch auf den Stand „3.0(328)“ ist ohne Erfolg.

Ich habe darauf hin das Update über das INSTAR Kamera Tool versucht. Sowohl bei der Update-Auswahl „Firmware“ als auch „WebUI“ läuft scheinbar alles durch, aber genauso erfolglos wie im Browser und mit dem Effekt, dass die Kamera nach der Update keine TCP-Verbindung mehr aufbauen will, bis sie vom Strom getrennt wird. Nach dem Update ist die Kamera im LAN sichtbar, sie verweigert aber jeden Connect, bis sie vom Strom getrennt wird. Ich brauche nicht zu erwähnen, dass danach wieder die alte FW angezeigt wird.

Ich komme zum Entschluss, dass hier einiges im Argen liegt und werde wohl an dieser Kamera bei der installierten FW Konfiguration bleiben.

Grüße
Jean

Und was passiert, wenn man auf das rote Update verfügbar klickt? Und ggf. auch mal einen Soft-Reset probieren. Damit die Konfiguration auf der Kamera wieder im Originalzustand ist. Nicht das da nur irgendwo ein Schreibfehler die Formatierung einer Konfig beschädigt hat.

Hallo,

Beim Klicken auf „Update verfügbar“ oder „Update“ passiert nicht viel, nach einigen Sekungen nur die Meldung „Update-Status: Update-Server konnte nicht erreicht werden. Bitte versuchen Sie es später nochmal“.

Holt sich die Kamera selbst das Update oder läuft das über den Browser? Ich kann im Netzwerkverkehr nur die HTTP-GET Anfrage vom Browser und die Antwort vom Updateserver sehen, aber danach sehe ich keine weiteren Daten mehr. Irgendwas scheint da zu klemmen.

Mit „Soft-Reset“ ist vermutlich der Werksreset gemeint. Das habe ich auch probiert, der Reset erfolgt auch nach dem, was die GUI anzeigt. Allerdings sind danach noch alle Einstellungen wie Alarm-Bereiche, ausgeblendete Bereiche etc erhalten. Ich hätte erwartet, dass nach einem Werksreset diese Konfiguration weg ist.

Ich werde als nächstes noch die SD-Karte formatieren, viel mehr fällt mir im Moment nicht mehr ein.

Grüße
Jean

Beim Autoupdate müssen die Port 4555…4557 offen sein. Siehe ganz unten

Danke für den Hinweis.

Soweit ich im Router sehen kann, sind nach aussen keine Ports gesperrt. Selbst eine vollständige Freigabe der Kamera als Exposed Host bringt keine Verbesserung.
Ich sehe das noch als getrennte Baustelle, unabhängig davon sollte das Update per update.pkg klappen - bei der zweiten Kamera hat das ja problemlos funktioniert.

Nachdem der Werksreset per Software nichts bewirkt, werde ich morgen die Kamera abbauen und den Reset per Knopf (Kap. 8 der Bedienungsanleitung) machen. Dem Verhalten nach ist die Konfiguration verkorkst.

Grüße
Jean

Das Update über den Auto-Updater ist i.d.R. „schonender“ da wir dort wissen auf welchem Stand die Kamera ist und dann nur das notwendige aufspielen.

Die Abfrrage ob ein neues Update verfügbar ist, läuft bei der WebUI über den Port 80. Und das funktioniert ja auch - die WebUI zeigt an, dass da was neues bereit steht.

Für das Herunterladen des Updates führt die Kamera ein wget auf den oben genannten Ports aus und holt sich dann nur die Bestandteile, die auf der Kamera fehlen. Da hier keine Standard Ports verwendet werden, hätte ich auch eine Sicherheitseinstellung im Netzwerk im Verdacht, wenn der Prozess zurückgibt, dass der Server nicht kontaktiert werden konnte (weil zuvor über den Port 80 war die Kontaktaufnahme ja möglich).

Nach dem Soft und Hard Reset gibt es noch eine weitere Möglichkeit - die gesamte Firmware noch einmal austauschen per Werks-Update. Aber das müsste der Support machen (man muss im Anschluss noch ein paar Dinge neu einrichten, damit die Kamera wieder läuft).

Danke für die vielen Infos über das Update.

Möglicherweise sind irgendwo Ports gesperrt, ich kann aber keine Stelle finden, weder in der Windows Firewall noch in der Fritzbox. Standardmäßig sollten ja alle Ports ausgangsseitig offen sein.

Für den Hard Reset versuche ich in den nächsten Tagen, die Kamera abzubauen. Das gestaltet sich aufgrund der Montage an einer Außenwand und der Kabelführung ziemlich mühsam.

Muss für den genannten Werks-Update die Kamera geöffnet werden oder könnte der per LAN an der aussen montierten Kamera durchgeführt werden?

Danke und Grüße
Jean

PS: Habe gerade im Wiki gesehen, dass das Wiederherstellen der Firmware über eine serielle Schnittstelle auf der Kamera-Platine erfolgt. Damit hat sich die Frage vermutlich erledigt.

Denk dran, beim Hard-Werksreset (Drücken des Resetknopfes für mind. 15 s) das LAN-Kabel** vorher abzuziehen**.