Unterschiedliche Absender der Alarmmails trotz gleicher Konfiguration

Grundsätzlich habe ich als Absender immer den vorkonfigurierten Eintrag von Instar benutzt.
Trotzdem habe ich, nachdem eine Cam an anderer Stelle platziert wurde und auch entsprechend der Name umbenannt wurde, noch die alte Bezeichnung „Tor“ als Emailabsender! Bei allen anderen 7 Cams steht dort immer cam@instar.email und nur bei der umbenannten steht dort einfach nur Tor!


Hallo @magnumthevoice ,

wenn man den INSTAR SMTP auswählt verschwinden ein paar Felder (die man nicht ausfüllen muss). Wenn man da stattdessen z.B. GMAIL auswählt tauchen die Felder wieder auf und man kann sie editieren und danach wieder auf INSTAR SMTP zurückstellen.

Man kann den hinterlegten Wert auch direkt per CGI auslesen und überschreiben:

Danke für die ausführliche Antwort :pray:

Ich wünsche noch einen schönen Tag

Magnus

1 Like

Auch wenn ich Gmail, GMX usw, eingebe, erscheint kein Feld mit dem Absender!

Und mit den CGI-Befehlen tue ich mich schwer! Habe den entsprechenden Parameter im Browser eingegeben und werde aufgefordert Nutzername und PW einzugeben! Doch die entsprechende Kombination, mit der ich mich sonst in der UI anmelde, werden nicht angenommen!

Da muss das Admin Login rein - also ein normaler User würde nicht ausreichen. Wenn es mit dem Admin Passwort nicht geht, kann es eventuell ein Problem mit Sonderzeichen sein. Die müssten URL encoded werden.

Was bedeutet URL encoded?
Ich bin wohl in solchen Dingen nicht versiert genug!

Wenn es Sonderzeichen gibt im Kennwort, können die eventuell beim Versenden über HTTP abgeschnitten werden. Man kann dann stattdessen Platzhalter versenden.

Solche Encoder gibt es auch online - z.B. hier:

Der macht z.B. aus $+>%24%2B%3E was URL-freundlich ist :slightly_smiling_face:

Weder im Namen, noch im PW sind Sonderzeeichen enthalten!

Und in der UI sieht es so aus, wenn ich versuchen würde die SMPT zu ändern!
Ich sehe keine Möglichkeit den Absender einzutragen???

Der Punkt ist unter dem Menü Email zu finden. Also erst bei SMTP das INSTAR Preset rausnehmen und dann nach Email gehen. Dort findet man dann auch das Feld Absender.

Habe erst unter SMPT das Preset herausgenommen und durch einen Fake ersetzt! Dann unter Mail den korrekten Absender eingegeben! Zum Abschluss dann unter SMPT manuell die Daten von Instar eingegeben, gespeichert und eine Testmail versendet. Und die Testmail hatte wieder den alten Absender…

Haben die Kameras denn alle die gleiche Firmware? Wenn ja, würde ich einmal probieren die Problem Kamera mit einem Softreset (über die WebUI mit Beibehaltung der Netzwerkeinstellungen) in den Werkszustand zu bringen.

Oder alternativ noch mal schauen ob man die CGIs nicht zum Laufen bekommt - wie gesagt, damit kann man auslesen was wirklich hinterlegt ist (auch wenn es nicht in der WebUI angezeigt wird).

Bei den CGI`s komme ich mit dem Nutzernamen ud PW der Cam immer noch nicht rein!
Wäre aber wohl der bessere Weg!
Vielleicht sollte ich mich mit dem Alten Absender abfinden…

Im Notfall kann unser Support per Fernwartung helfen - das ist schwer da die Fehlerquelle einzugrenzen ohne das System zu sehen.

Okay!
Wenn ich nicht weiterkomme, werde ich den mal kontaktieren!

Vielen Dank für die Mühe

1 Like

Hallo!

Ich habe noch eine Frage zu den CGI!

Wo und wie muss ich in der unteren Zeile „var ma_subject“ oder „var ma_from“ eingeben?

Statt param.cgi???

http://admin:instar@192.168.2.168/cgi-bin/hi3510/param.cgi?cmd=getsmtpattr

Hallo,
param.cgi bleibt bestehen. Die Parameter werden durch &- als Kette aneinandergehängt. Man muss noch unterscheiden, ob man Parameter aus der Kamera abfragen möchte (GET), oder Parameter setzen möchte (SET).
Unter obigem Link zu den CGI-Kommandos sind auch gleich zwei Beispiele für SET oder GET-Kommandos zu finden.
Grüße

Example GET: http://admin:instar@192.168.2.168/cgi-bin/hi3510/param.cgi?cmd=getsmtpattr

SET: http://admin:instar@192.168.2.168/cgi-bin/hi3510/param.cgi?cmd=setsmtpattr&-ma_from=my@email.com&-ma_to=my2nd@email.com;&-ma_subject=Alarm&-ma_text=Alarm

Hallo!

Hab es gerade wohl verstanden!

Habe den Befehl ausgeführt und bekomme unter anderem folgende Antwort:

var ma_from=„cam@instar.email“

der Absender ist laut CGI korrekt, aber bei den erhaltenen Mails steht leider immer nur Tor!

Wäre kein großes Problem, nur die Cam heißt jetzt Einfahrt! Ist daher etwas verwirrend!
Wenn als Absender cam@instar.email stünde und im Betreff Einfahrt, wäre das so wie bei den anderen Cams!

Befindet sich das „Tor“ denn noch irgendwo in der Konfiguration der Kamera? Zum Beispiel als Kameranamen?

Man kann auch den Namen, Modellnamen und die Geräte ID per CGI auslesen - mal schauen ob das da irgendwo dabei ist:

/param.cgi?cmd=getserverinfo
/param.cgi?cmd=getsysinfo

/param.cgi?cmd=getserverinfo
/param.cgi?cmd=getsysinfo

Bei beiden Befehlen taucht der Begriff „Tor“ nicht einmal auf!!!

Bei dieser Cam wird der Absender in Outlook so angezeigt: "Tor cam@instar.email
Bei den anderen Cams steht da einfach nur: cam@instar.email

Die aktuelle SMTP Konfiguration habe ich noch mal als jpg angehängt!

Der Absender ist definitif cam@instar.email aber angezeigt wird er als Tor <cam@instar.email!