P2p oder ddns funktionieren nicht mehr

Hallo zusammen, habe eine 5905HD die an meiner Fritzbox hängt. Portweiterleitung 8081 und 1935 sind konfiguriert. Seit kurzem habe ich einen neuen Provider mit einem Huawei-Router an dem dann meine Fritzbox das interne Netz bildet, mit der Kamera die dann auch im internen Netz an der Fritzbox hangt. Seit dem neuen Provider, mit seinem Router, kann ich die Kamera nicht mehr aus dem Internet über p2p oder ddns erreichen. Was müsste auf dem Provider-Router konfiguriert werden, damit die Kamera wieder erreichbar ist.

Hallo,

Du hast Dir die Lösung schon fast selber geschrieben:

Der neue Router muss genauso konfiguriert werden, wie die FB vorher.
Grüße

Frage

  1. hast du weiterhin eine öffentlich IPv4 Adresse von deinem neuen Provider?
  • wenn nicht dann geht der Zugriff auf die DDNS Adresse von Außerhalb nicht.

Für P2P benötigt man keine Portweiterleitung!
Für DDNS muss eine Portweiterleitung im Providerrouter auf die WanIP der Fritzbox gemacht werden!
In der Fritzbox muss die Portweiterleitung auf die jeweilige IP der Kamera gemacht werden.
Gruß
Hbr

Hallo und danke für eure Teilnahme an meinem Problem.
Was heißt, Hast du eine öffentliche IP vom Provider: Mir ist keine explizit mitgeteilt worden, jedoch gibt es auf dem Router natürlich eine öffentlich IP oder verstehe ich da etwas falsch? Ich habe ja auch die Zugangsdaten für deren Router und habe da auch schon „versucht“ eine Portweiterleitung einzurichten. Aber ohne Erfolg für meinen DDNS Zugriff.
Die öffentliche IP kann ich auslesen, aber die wird sich ja von Zeit zu Zeit ändern, ODER?
Wenn ich für P2P keine Portweiterleitung benötige, warum klappt es dann auch damit nicht.
Ich hoffe, dass ich nicht nerve mit meinem Halbwissen.
Grüsse

Bei „öffentlicher IP“ ist eine IPv4-Adresse gemeint, anstelle IPv6. Mein Provider hat mir nach einem Routerwechsel auch still und heimlich eine IPv6 untergejubelt.
Im Router kannst Du sehen, ob Du noch eine IPv4 hast, oder Du gehst auf https://www.wieistmeineip.de/
Grüße

Edit: Es gibt auch noch IPv4 über DS-Lite. Da funktioniert die Portfreigabe anscheinend auch nicht mehr oder mit mehr Aufwand.

ist noch eine IP4-Adresse: 149.36.234.97.
Weisst du zufällig wie die Portfreigabe in einem Huawai EchoLife eg8141A5 eingerichtet wird.
Ich habs so gemacht:
Type: User-defined Application
Application:
Select…
Enable Port Mapping:
Mapping Name:
instar
WAN Name:
3_INTERNET_R_VID_1021
Internal Host:
192.168.18.3
*
fritz.box
External Source IP Address:

Protocol:
TCP
Internal port number:
8081

8081
*
External port number:
8081

8081
External source port number:

Delete
Protocol:
TCP
Internal port number:
1935

1935
*
External port number:
1935

1935
External source port number:

Wie lautet die Ip Adresse der Fritzbox und wie die der Huawai ?
Ist die 192.168.18.3 die Ip Adresse des Wanport ( der zur Huawai Box geht) der Fritzbox ?
Frage bitte bei deinem Provider nach ob du noch eine öffentlich Ipv4 Adresse bekommst.

Frage: warum hast du noch die Fritzbox dazwischen?

Gruß
Hbr

IP-Fritzbox 192.168.18.3
huawei 149.36.234.97 / 192.168.18.1

Die IP vom Provider, die ich anfragen soll, die müsste ja dann ein statische/feste sein, oder?

Die Fritzbox habe ich noch, da ich dort mein ganzes Heimnetz konfiguriert habe. Da hängen DECT-Telefone dran, VoIP ist konfiguriert, die Kamera, Fotovoltaik, usw. Wechsle ich den Provider, dann hänge ich die Fritzbox dran und alles läuft wieder, außer der Kamera :joy:

Nicht welche IP (die sich täglich ändern kann) sondern ob du noch eine öffentliche IPv4 Adresse bekommst - welche ist dabei unwichtig

Es sind also beide Router im selben Subnet ( Ip-Bereich )
Ist als Gateway in deinen Geräten ( Kamera/ PC / Smartphobne) die IP Adresse der Fritzbox oder die des Huawai Router eingetragen?

  • ebenso der DNS Eintrag
    Wie ist denn die Ip-Konfiguratiion der Fritzbox?
    Ist die Fritzbox auch noch der DHCP Server?
    Haben die Kameras überhaupt noch Zugriff auf das Internet?

ok, werde mal eine IP beim Provider anfragen.
Ja, beide Router sind im selben Subnet, als Gateway ist die IP der Fritzbox eingetragen. Die Fritzbox ist als Vorhandener Zugang über LAN, konfiguriert und DNS-Server ist der Huawei-Router. Die Fritzbox ist der DHCP server für die angeschlossenen Geräte.
Ob die Kameras noch Zugriff auf das Internet haben weiss ich nicht, oder doch, fällt mir gerade ein, wenn ich nach Updates für die Kamera suche, funktioniert noch alles.

Hallo, ich habe nochmal eine Frage.
Wenn ich mich auf den Provider-Router verbinde und dann die Adresse der Kamera (192.168.2.104) eingebe, dann funktioniert das nicht, da der Provider Router ja die Fritzbox mit seiner vergebenen DHCP Adresse, in dem Fall die 192.168.18.3 kennt. Die Fritzbox hat im LAN der Fritzbox die Adresse 192.168.2.2 und alle angeschlossenen Geräte 192.168.2.xxx. Das sagt mir, das der Provider-Router das Netz der Fritzbox mit seinen DHCP Adressen gar nicht kennt. Gebe ich über CMD nslookup ein, dann bekomme ich die Fritzbox mit ihrer IP und wenn ich dann weiter die DDNS der Kamera eingebe, bekomme ich als Antwort auch die WAN-IP zurück. Aber anscheinend funktioniert das nicht aus dem Internet mit der DDNS oder auch mit der WAN-IP. Hoffentlich habe ich mich hier verständlich ausgedrückt und nicht so sehr verwirrend. Wo könnte das Problem hier liegen.

Eher verwirrend.

???

Die Fritzbox hängt mit ihrem WAN-Port am LAN-Port des Huawei-Routers. Und wenn der Huawei-Router die Kameras nicht sieht, dann können die beiden Router nicht im selben Subnetz liegen.
Wenn die Maske jeweils 255.255.255.0 beträgt, dann hast Du einmal das Netz 192.168.2.0…255 und 192.168.18.0…255
Die Maske im Huawei-Router müsste angepasst werden, damit die FB mit den Kameras sichtbar werden. Oder setze einfach die IP des Huawei-Routers auf die vorige IP der FB.
Die Portweiterleitungen im Huawei-Router müssen ebenso eingetragen werden, wie bisher in der Fritzbox. Dann sollte der Zugriff aus dem Internet eigentlich funktionieren.
Grüße

Nein, es muss im Huawei Router EINE Portweiterleitung ( Alle Ports der Kameras )auf die WanIp (192.168.18.3) der Fritzbox gemacht werden und in der Fritzbox sind sie ja noch vorhanden oder?
In der Fritzbox muss für jede Kamera eine Portweiterleitung auf die lokale Ip der jeweilige Kamera gemacht werden.

Gruß
Hbr

Ich hatte darüber vor längerer Zeit mal eine Skizze gemacht.

siehe Bild

Router 1 = der Huawei
Router 2 = Fritzbox

Hatte ich doch auch so beschrieben? Alle Portweiterleitungen vom alten Router (Fritzbox) müssen auch noch im neuen Router (Huawei) angelegt werden.
BTW: Gute Zeichnung, die erklärt mehr als tausend Worte.

Nein, denn das könnte man dann so verstehen dass sie identisch sein müssen.

  • gleiche Ports auf gleiche Ip Adresse.

und das wäre dann falsch.
Aber in der Skizze kann man sicher erkennen was ich meine

Hallo und danke für die rege Teilnahme.

Also bei mir ist es so.
Der Huawei Router (Provider) hat die IP 192.168.18.1. und die Fritzbox wird im Huawei mit der IP 192.168.18.3 angezeigt.
Auf dem Huawei ist eine Portweiterleitung auf die 192.168.18.3 der Ports 8081, 1935, 554.
Die Fritzbox hat den vorhandenen Zugang über LAN mit der IP 192.168.18.3.
In der Fritzbox sind Portfreigaben, (-weiterleitungen) für die Kamera (192.168.2.104) eingerichtet, auf 8081, 1935 und 554. Ich habe einfach mal Weiterleitungen für alle Ports die in der Kamera angegeben sind, eingerichtet, ob die da auch Bedeutsam sind weiß ich nicht. Als IP im Internet wird auf der Fritzbox die 192.168.18.3 angezeigt. Die Fritzbox bildet mein Heimnetz ab und hat dann im Heimnetz die Adressen 192.168.2.2 wobei dann alle Geräte im Netz der Fritzbox die IPs von 192.168.2.xxx haben. DHCP
Die IP Konfiguration der Kamera:
IP-Adtesse: 192.168.2.104
Sup-Net: 255.255.255.0
Gateway/DNS: 192.168.2.2
HTTP-Port: 8081
RTMP-Port: 1935
RTSP-Port: 554

So, mit diesen Einstellungen funktioniert es nicht. Jetzt weiss ich nicht ob ich nun die IP des Huawei an die IP der Fritzbox anpassen soll 192.168.2.xxx oder der Fritzbox eine Adtesse des Subnetzes des Huawei-Routers verpassen muss. 192.168.18.xxx. Oder was sonst zu tun ist.

Mein Tipp wäre:
eine der Kameras direkt mit dem Huawei Router zu verbinden und ihr eine Ip-Adresse
aus dem Bereich 192.168.18.0 vergeben sowie Gateway und DNS anpassen.
Dann eine Portweiterleitung im Huawei Router auf die IP-Adresse der Kamera zu machen.
Wenn es dann auch nicht geht ist der Fehler im Huawei oder bei dem Provider zu suchen.
Frage: sitzt dein Provider in Deutschland?
Ist es zwingend Notwendig das der Huawei Router den Internetzugang herstellt?
Gruß
Hbr

nein, der Provider ist in Spanien, ich lebe in Spanien. Der Huawei-Router stellt den Internetzugang her. Das mit deinem Vorschlag habe ich mir auch schon einmal überlegt, allerdings muss ich dann immer Anpassungen vornehmen, wenn ich mal einen Provider Wechsel habe. Das war und ist ja das schöne, das ich immer an der Fritzbox, die mir gehört, alles konfigurieren kann, also alle in meinem Netz befindlichen Geräte. Wenn ich es allerdings nur auf diesem Wege schaffen sollte, dann wird mir wohl nichts anderes übrigbleiben.
Danke

Das soll ja auch nur zum Test sein um erstmal eine Fehlerquelle (Fritzbox) auszuschließen.
Denn wenn es dann auch nicht funktioniert liegt ja der Fehler entweder in dem Huawei -Router ( Portweiterleitung / Firewall usw.) oder bei dem Provider.
Sollte es dann funktionieren liegt der Fehler entweder in der Portweiterleitung im Huawe zur Fritzbox oder in der Portweiterleitung der Fritzbox

dachte ich mir schon - da deine Wan Ip auf Spanien hinweißt.

Gruß
Hbr