IN-8015 FullHD: features/nightvision/autoircut schaltet nicht

Hi!

Ich habe zwei IN-8015 FullHD Kameras über LAN (PoE) in Betrieb.
Genutzt wird ein externer Mosquitto-Dienst (auf NAS) mit SSL-Verbindung.
Einrichtung ist abgeschlossen und das Setup wird bereits erfolgreich genutzt.

Ich versuche derzeit, die Einstellung „features/nightvision/autoircut“ über MQTT einzustellen.
Der gesetzte Status wird dann jedoch nicht über „status/features/nightvision/autoircut“ angezeigt.
Ein Umschalten des IRCut-Filters in der Kamera findet ebenfalls nicht statt.

Schaue ich mir das entsprechende Menü (IR-Nachtsicht) aber in der WebGUI an, ist bei jedem Öffnen des Dialogs der über MQTT gesetzte Status zu sehen (Automatisch, Tagesmodus, Nachtmodus).
Ein Klick auf Übernehmen ändert aber effektiv nichts.
Ich muss dann zunächst in der GUI einen anderen Wert wählen, dann „Übernehmen“ und kann dann wieder in der GUI umschalten. Diesmal reagiert dann auch wieder die Hardware.

Dummerweise wird der über die GUI gesetzte Status auch nicht über MQTT wiedergegeben.
Das passiert nur ein einziges Mal, nämlich direkt nach dem Verbindungsaufbau, wenn man in den Netzwerkstellungen unter „MQTT“ den Punkt „MQTT aktivieren“ aus- und nach dem Übernehmen wieder einschaltet.

Ich hatte diese Einstellung bisher immer über CGI-Befehle vorgenommen.
Das funktioniert auch weiterhin, aber ich würde gern komplett auf MQTT wechseln.

Wie gesagt, zwei Kameras zeigen ein identisches Verhalten. Details:

IN-8015 FullHD PoE (Aktuell)
Firmware-Version: 4.1.2.48
WebUI-Version: 3.0(326)

Wenn ich zum Testen statt „autoircut“ die Option „autoled“ verwende, klappt alles.
Es scheint also nur diese eine spezielle Option betroffen zu sein.

Kann das Verhalten jemand bestätigen? Habe ich was vergessen / falsch gemacht?

Danke + Gruß
Thomas

Hallo @cupracer,

und willkommen im Forum.

Es sind insgesamt 4 Punkte die da geschaltet werden müssen:

  1. Die IR LEDs
  2. Der IRcut Filter
  3. Der obere Schaltpunkt des IRcuts
  4. Der untere Schaltpunkt des IRcuts

Punkt 2 ist dabei nur eine Variable, über die wir die Anzeige in der WebUI einstellen - „IRcut automatisch“ oder „IRcut deaktiviert“. Aber das eigentliche Verhalten, das man dadurch einstellen möchte, wird durch die beiden Grenzwerte bestimmt:

IR LEDs & IRcut automatisch

cmd=setinfrared&-infraredstat=auto
cmd=set_instar_admin&-index=2&-value=auto
cmd=setircutattr&-saradc_switch_value=208&-saradc_b2c_switch_value=190

features/nightvision/autoled {"val":"auto"}
features/nightvision/autoircut {"val":"auto"}
features/nightvision/upperirthreshold {"val":"208"}
features/nightvision/lowerirthreshold {"val":"190"}

Disclaimer: 208/190 sind die Standardwerte der IN-8015 FHD. Diese Werte sind abhängig vom verbauten Helligkeitssensor und kann auch bei späteren Chargen der 8015 anders sein. Am besten immer erstmal schauen was die Kamera als Standardwerte hinterlegt hat.

IR LEDs & IRcut deaktiviert (Nachtmodus)

cmd=setinfrared&-infraredstat=close
cmd=set_instar_admin&-index=2&-value=close
cmd=setircutattr&-saradc_switch_value=1&-saradc_b2c_switch_value=1

features/nightvision/autoled {"val":"close"}
features/nightvision/autoircut {"val":"close"}
features/nightvision/upperirthreshold {"val":"1"}
features/nightvision/lowerirthreshold {"val":"1"}

IR LEDs automatisch IRcut aktiv (Tagmodus)

cmd=setinfrared&-infraredstat=auto
cmd=set_instar_admin&-index=2&-value=open
cmd=setircutattr&-saradc_switch_value=270&-saradc_b2c_switch_value=270

features/nightvision/autoled {"val":"auto"}
features/nightvision/autoircut {"val":"open"}
features/nightvision/upperirthreshold {"val":"270"}
features/nightvision/lowerirthreshold {"val":"270"}

Vielen Dank für die schnelle Hilfe!

Offenbar hatte ich mich mit dem Thema bereits damals beschäftigt, als ich die CGI-Befehle für die Verwendung in Homematic-Skripten zusammengestellt habe:

/param.cgi?cmd=setinfrared&-infraredstat=auto&cmd=set_instar_admin&-index=2&-value=auto&cmd=setplancgi&-plancgi_enable_0=0&-plancgi_enable_1=0&cmd=setircutattr&-saradc_switch_value=270&-saradc_b2c_switch_value=270

Bis zur der jetzigen Umstellung auf MQTT hatte ich das wohl alles bereits wieder vergessen und war nun dabei, mich um jeden Schalter einzeln zu kümmern. Hier war meine Erwartung, dass der IRCut-Filter-Schalter ausreicht, um die Kamera „klicken“ zu lassen… als das ausblieb, bin ich gänzlich von der Fährte abgekommen.

Mit den MQTT-Schaltern oben funktioniert aber nun wie gewünscht.

Nochmal vielen Danke + viele Grüße!

Thomas

1 Like