Fehlermeldung im Iobroker?

Man müsste da an irgendner Datei rumfummeln. Ich benutze den IoBroker selbst nicht, aber nach Rücksprache mit nem Kollegen ist es vielleicht möglich den State der Instar Kamera zu resetten indem der Instar Tree über die GUI gelöscht wird. Also Rechts-Klick auf den Instar Eintrag, löschen, neustarten und den Instar Tree mit den Kameras neu hinzufügen.

Alternativ kannst du auch erst eine neue Instanz anlegen indem du einen neuen Mqtt Adapter für die Kamera erstellt. Dann sollte der State neu sein. Zumindest weiß man dann, dass es an dem gespeicherten State liegt.

Danke dir…auch wenn ich leider überhaupt nicht verstehe was du meinst :stuck_out_tongue_winking_eye:

Ich würde mal probieren einen externen (MQTT) Broker zu verwenden und im ioBroker dann den MQTT „nur Client“ Adapter zu verwenden.

Den neuen Mosquitto Broker 2.0 hat man sehr schnell aufgesetzt und auch das Hinzufügen von Klienten ist da - dank der neuen Benutzeroberfläche - sehr übersichtlich:

Danke für die Hilfe.
An den Mosquitto Broker 2.0 habe ich mich noch nicht rangetraut da ich im Netz keine für mich brauchbare Anleitung zum installieren gefunden habe. Habe ja auf dem Raspi ein jetzt lauffähiges System mit dem Iobroker und weiß eben nicht ob und wie man den Mosquitto Broker 2.0 jetzt noch hinzu bekommt. Aber vielleicht finde ich ja noch eine brauchbare Anleitung… :flushed: :flushed: :flushed:

Man kann auch die Kamera zum Broker machen und den ioBroker Adapter als Klient konfigurieren.

@m.polinowski

Ja, Ihr habt da ein echt gutes Wiki! :+1:
Aber auch dort, den Adapter im ioBroker als Klient eingesetzt, werden „halbautomatisch“ Objekte angelegt in Form der raw-Topics. Im Falle einer Neuinstallation des MQTT Adapters ist das dann weg und muss „halbautomatisch“ wieder angelegt werden.
Aber mir scheint, dies ist wohl die Wahl.

Eure Variante den ioBroker Adapter als Broker einzusetzten hatte ich bisher. Aber nachdem diese Fehlermeldungen mit Sendefehlern kamen (hat aber alles funktioniert) und gelesen habe, als Broker ist der Adapter nicht so zuverlässig, habe ich angefangen, die Mosquitto Variante zu installieren.
Den Broker auf der Kamera möchte ich nicht nutzen (auch wenn das eine klasse Sache ist), da ich unterschiedliche MQTT Geräte habe die erstmal unabhängig von einem speziellen Gerät (der Kamera) sein sollen und der Broker natürlich frei konfigurierbar. Ist aber auch Philosophie.

1 Like

Also, ich habe meinen Gordischen Knoten gelöst.
Wenn ich auf ein anderes Forum verlinken darf - hier habe ich erklärt, was meine Lösung war bzw. wo wohl das Problem war.
Jetzt habe ich Mosquitto als (neutralen/unabhängigen) Broker, der zwischen den Kameras etc. und ioBroker vermittelt.
Danke für die Denkanstöße!

@jokerjo1000
Gerne helfe ich dir, dieses Scenario aufzusetzen. Jetzt kenne ich den Weg und das sollte max. 30min dauern, dann läuft es. Nicht 2,5 Tage, wie bei mir :rofl: :crazy_face:
Die Fehlermeldungen gibt es dann nicht mehr.

1 Like

Das hört sich doch gut an. Gerne würde ich deine Hilfe in Anspruch nehmen :stuck_out_tongue_winking_eye: