Alarmserver und Fhem funktioniert nicht

Hallo zusammen,

ich weis es ist ein viel diskutiertes Thema hier und es gibt auch schon antworten auf viele Fragen. Dennoch glaube ich mein Problem wurde hier noch nicht diskutiert.
Ich möchte das meine Cam im Falle eines Alarms FHEM benachrichtigt, dazu habe ich die entsprechenden Wiki-Einträge gelesen.

Cam 5905HD Software 3.1.2.66 GUI 1.18

Hier im Bild die Konfiguration in der CAM. Diese sieht meines erachtens in der Vorschau auch gut aus.

Am FEHM Server kommt jedoch das an (Wireshark Trace). Ohne Port im GET und mit einem ? am Ende.

Mit dem Browser gehts und man sieht im Trace auch das anders als bei der Cam ein Port im GET steht und am Ende das ? nicht vorhanden ist.

Fhem lehnt die Anfrage von der Cam ab, da der Port nicht passt und evtl. ist ? auch ein Problem.

Hat jemand eine Idee ob ich das auf der Cam beeinflussen kann?

Danke und Grüße
fhem1977

Servus,

Ich möchte das meine Cam im Falle eines Alarms FHEM benachrichtigt,

das machen meine Cams schon seit Monaten :icon_wink:, mit folgenden Settings:

Serverport: 8083 (sollten auch die anderen eingerichteten gehen)
Serverpfad: /fhem
Im Feld Attribut 1 schreibts Du:cmd
Im Feld Wert 1 schreibst Du: set TuerAlarmD on

So, daß die Befehlskette in der Vorschau nach der Portnummer wie folgt aussieht:

/fhem?cmd=set%20TuerAlarmD%20on

Und der TuerAlarmD muß natürlich ein in FHEM definierter Dummy sein.

gruss

Hallo Suedharzer,

funktioniert :-)). Vielen Dank für die schnelle Hilfe. Zur Vollständigkeit hier die Einstellungen als Bild für alle die auch drüber stolpern.

Grüße
Stephan

:icon_thumbs1:

und nur nebenbei für die Zukunft:
Eine private 192.xxx.xxx.xxx braucht Du nicht zu verpixeln, die wird sowieso nicht geroutet.

Meine 7011 hat z.B. die 192.168.178.35:icon_biggrin:

gruss

Und dann habe ich z.B. noch einen Dummy „alarm_schalter“, der über ein Notify die Alarm-Notifies aller Cams auf aktiv bzw. inaktiv setzt.
Das heißt, über diesen Dummyschalter kann ich die Alarmserverfunktion aller Cams für FHEM bei Bedarf/Zeit/Event ein- oder ausschalten.:cool:

gruss

Hallo,
hat jemand schon die Alarmbereiche (im Syslog „mdio(area=XXXX)“ im Fhem abgefangen?
In der Kamera gibt es den Button "Alarmauslöser anhängen) -> dieser Button bewirkt „&active=1“
Wie sieht die http-query dann aus?

Gruß
Martin

Hallo @MartinD ,

der Query für den SysLog? Das haben wir hier z.B. für Node-RED beschrieben:

https://wiki.instar.de/Erweitert/Node-RED_und_SQL-Logging/#sichern-sie-das-systemprotokoll-ihrer-kamera

INSTAR Support