Alarmbereiche, MQTT und ioBroker

Hallo INSTAR-Community,

ich habe mir drei 9008 PoE zugelegt, die auch so weit ihren Dienst - Was ich bis jetzt so getestet habe - ordentlich verrichten.

Aber was ich nicht ganz verstehe ist folgendes …

Ich habe bei einer Kamera zwei Alarmbereiche die mit PIR gekoppelt sind.

Nehmen wir Alarmbereich 1, der im MQTT-Adapter vom ioBroker mit Datenpunkt mqtt.0.instar.XXXXXXXXXXXX.status.alarm.triggered getriggert werden kann. Soweit alles gut!

Der Wert für Alarmbereich 1 & PIR ist „val“: „7“
Der Wert für Alarmbereich 2 & PIR ist „val“: „8“

Kreuzt jemand Alarmbereich 1 wird getriggert bei Alarmbereich 2 ebenso.

Was mir gar nicht gefällt ist …
Wurde nur Alarmbereich 1 getriggert und nochmal durchlaufen wird dieser NICHT mehr getríggert sofern nicht ein anderer Alarmbereich zB.: Alarmbereich 2 getriggert wurde.

Warum gefällt mir das nicht.
Weil ich der letzte bin der den Alrambereich 1 durchquert (Wegen Hund und letzter Pippi bevor es schlafen geht)

Komm jetzt ein Böser Mensch und durchquert Alambereich 1 als erstes wird nichts gertriggert. Ich erhalte keinen Snapshot ind kein Alarm wird ausgelöst.
Schlecht, sehr schlecht

Sollte ich Gedanklich was falsch sagen oder denken?

Hallo,
ohne den Flow zu kennen: Du müsstest bei den Switch Nodes mal nachsehen, ob dort die Option „checking all rules“ aktiviert ist.
Grüße

Es gibt momentan ein Problem mit dem alarm/triggered Topic. Intern ist es bereits behoben und der Fix wird mit dem nächsten Update dann bereitstehen.

Der Alarmserver fällt z.Z. nicht zurück auf {"val":"0"} - d.h. wenn er einmal mit z.B. 7 ausgelöst wurde und dann später nochmal die 7 kommt, sieht der ioBroker das nicht als Änderung und es wird nichts getriggered. Normalerweise fällt der Wert nach 5s wieder auf Null und wird damit zurückgesetzt.

Man könnte in ioBroker (Blockly, Node-Red) auch ein script anlegen das genau das macht - einfach nur nach einem Alarm den Wert Null an status/alarm/triggered senden und schon sollte wieder alles laufen. Ansonsten wieder nach dem nächsten Update.

Supi, ich dachte schon …

Aber ich habe als Alternative den Alarmserver „zu Rate“ gezogen :slight_smile:
Der schlägt sofort und bei jeder Durchquerung/Erfassung an!

Danke für die Info