Ankündigung

Einklappen
Keine Ankündigung bisher.

13 Kameras zeitgleich down - Zugriff auf syslog möglich?

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Problem 13 Kameras zeitgleich down - Zugriff auf syslog möglich?

    Hallo Forum,

    heute morgen sind von unseren ca. 60 Kameras (die meisten davon Instar, ein paar wenige Foscam, Axis, Mobotix) 13 Kameras ausgefallen. Wir überwachen die Kameras mit Nagios und können deshalb nachvollziehen, dass die Kameras ab ca. 8:40 Uhr ausgefallen sind. Bei den 13 Kameras handelt sich durch die Bank um Instar 2905, Firmwarestand 57.35.2.59, teilweise auch 17.25.2.47, die meisten davon über PoE, eine wird werden über ein eigenes Netzteil versorgt.
    Das Problem war schnell behoben: Wir haben die Kameras über die gemanageten Switche PoE-stromlos gemacht und wieder eingeschalten bzw. bei der einen Kamera das Netzteil aus- und wieder eingesteckt.
    Nun würde ich gerne versuchen, das Problem zu lokalisieren. Da es sich bei allen Kameras um dasselbe Modell handelt, vermute ich einen Bug in der Firmware.

    Nach meinem Roman komme ich jetzt zur Frage: Gibt es eine Möglichkeit, auf das Syslog der Kameras zuzugreifen? Im Webinterface gibt's unter "System" die Option "Log", das sieht mir aber ganz und gar nicht nach einem typischen Syslog aus.

    Danke für eure Hilfe!
    -omtr
    Zuletzt geändert von omtr; 04.03.2015, 11:38.

  • #2
    Zitat von omtr Beitrag anzeigen
    Bei den 13 Kameras handelt sich durch die Bank um Instar 2905, Firmwarestand 57.35.2.59, teilweise auch 17.25.2.47, die meisten davon über PoE, eine wird werden über ein eigenes Netzteil versorgt.
    Das klingt schon mysteriös -

    Was bedeutet "ausgefallen"? Bild weg, kein Zugriff mehr über die IP, ping nicht mehr möglich, .....

    Ich bin schon lange genug dabei, aber sowas habe ich noch nie gehört.
    Nach einigem Grübeln kann ich hier nur ein lokales Problem vermuten.

    Vermutung: Spannungsunterschreitung in den Netzsegmenten um 0,x Volt, was die INSTARs evtl. nicht mehr tollerieren, andere Kameras aber noch wegstecken.
    Wenn einfach der benötigte Strom weg ist, wird auch nichts in ein Syslog geschrieben (wenn du einem PC den Stecker ziehst ..... wird sowas auch nicht geloggt)

    Verbuche das hier und jetzt mal als "shit happend". Erst wenn das nochmals oder öfters vorkommt, müsste man der Sache auf den Grund gehen.
    Einen FW-bug kann man wohl auch ausschliessen. Würde da in der Uhrzeit und /oder Kalender ein Käfer sitzen, würden ja alle diese Modelle am gleichen Tag zur gleichen Zeit ausfallen.

    Gruss
    Michael

    Kommentar


    • #3
      Hallo Muck,
      danke für Deine Hilfe.

      Fehlerbild: Kamera lässt sich nicht über http ansprechen, auf unserer Aufzeichnungssoftware ist kein Bild nicht mehr sichtbar und die Kameras pingen auch nicht mehr.

      Klar: wenn es tatsächlich der Strom ist, wird auch nichts geloggt.

      Spannungsabfall würde ich ausschließen, weil wir zentrale USVs haben und die Switche auch an unterschiedlichen Stromkreisen hängen, die 50 Meter und mehr auseinander liegen. Spannungsspitzen werden ebenfalls durch die USV weggefiltert.

      Nochmal syslog: die GET/POST-Befehle für die Kameras geben auch nicht mehr her, als das Webinterface - ich vermute mal, dass man schlichtweg nicht mehr sieht, als das Logfile im Webinterface hergibt - zumal ja offenbar ein Zugriff per Telnet oder SSH nicht möglich ist...

      Für mich ist das alles auch sehr mysteriös, irgendwie riecht das nach Y2K-Problem, so in die Richtung: Zeitabgleich per NTP nicht mehr möglich, alle Kameras gehen auf 1.1.1970 und spielen deshalb zum gleichen Zeitpunkt verrückt. Auch das ist für mich extrem unwahrscheinlich, wäre aber das einzige, was ich mir theoretisch (obwohl auch irgendwie lachhaft) vorstellen könnte. Oder es ist ein TCP-Paket-of-Death und wir erleben gerade einen Innenangriff ;-)
      Oder aber: die Kameras wurden von innen weggeDOSt - ich schau mir mal die Graphen im Nagios an...

      Schöne Grüße
      -omtr

      Kommentar


      • #4
        Zitat von omtr Beitrag anzeigen
        und die Kameras pingen auch nicht mehr
        Also total abgeschossen -

        irgendwie riecht das nach Y2K-Problem
        War mein erster Gedanke, als du von "FW-bug" schriebst.

        Oder es ist ein TCP-Paket-of-Death
        Das ist gar nicht so abwägig.
        Habe erst kürzlich so einen Fall gelesen. In einer Fa. wurde eine Überwachungssoftware für IP-Kameras installiert. Von dem Augenblick an, waren alle (7 Stück) Kyocera Drucker tot. Andere Drucker waren nicht betroffen.
        Die Software hat wohl genau diesen Druckertyp totgepingt
        Evtl. war in eurer Fa. zu dem Zeitpunkt auch irgend sowas im Netz unterwegs -

        Gruss
        Michael

        Kommentar

        Lädt...
        X