Ankündigung

Einklappen
Keine Ankündigung bisher.

Node-RED und IFTTT

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #46
    Hallo Markus2806 ,

    Ich habe mir das ganze nochmal - basierend auf deinem Code - angeschaut und zum Laufen gebracht. Damit es etwas übersichtlicher formatiert ist, habe ich es hier in ein FAQ gepackt:

    https://wiki.instar.de/Frequently_As...RED_and_IFTTT/

    Ich hatte ein paar Dinge geändert - z.B. einmal die DDNS einer AVM Fritzbox genommen, anstatt der INSTAR DDNS und auch den Zugriff ohne HTTPS eingerichtet. Aber auch mit dieser Konfiguration funktioniert es.


    Als Debug-Schritte ist es wichtig den Hook auf der Node-RED Seite erst einmal über die lokale IP auszuprobieren. Und auch den IFTTT Webhook kann man über den Browser aufrufen und schauen ob man da eventuell eine Fehlermeldung erhält. Ich hatte anfangs ein paar Tip- und Klickfehler in meinem Setup, die man damit schnell ausmerzen konnte.

    Kommentar


    • #47
      Hallo INSTAR

      vielen Dank für das FAQ.
      Leider musste ich meinen Raspi komplett neu installieren, weil ich mir die Settings.js Datei verhunzt hatte und nicht mehr auf das Node-Red gekommen bin.
      Hab dann alles nochmals installiert und bin der FAQ gefolgt. Jetzt funktioniert es auch
      Einziger Unterschied ist, dass ich diesmal keine Änderungen in der Settings.js Datei durchgeführt habe.
      Hier hatte ich ja die "adminAuth" aktiviert. Dies wird wahrscheinlich auch der Grund gewesen sein, wieso er nicht weiter gekommen ist.

      Jetzt frage ich mich, kann ich die adminAuth trotzdem aktivieren, dann müsste ich aber den Benutzer und Passwort mitgeben?
      http://benutzer:passwort@xy.ddns.net...alarm/md/areas

      Wie löse ich das ganze mit einer zweiten Kamera? Ich habe für jede Kamera einen eigenen Flow erstellt.
      Kann ich irgendwo mitgeben, dass entweder Flow1 oder Flow2 ausgeführt wird?

      Kommentar


      • #48
        Zitat von Markus2806 Beitrag anzeigen
        Hallo INSTAR
        Jetzt frage ich mich, kann ich die adminAuth trotzdem aktivieren, dann müsste ich aber den Benutzer und Passwort mitgeben?
        http://benutzerasswort@xy.ddns.net...alarm/md/areas
        Kurz - Ja

        Man muß zwingend die Authentifizierung bei Node-RED aktivieren, wenn man die Oberfläche im Router durchleitet. Es gibt da draußen leider böse Menschen, die einem sonst Crypto-Miner oder schlimmeres auf dem Pi installieren.


        Zitat von Markus2806 Beitrag anzeigen
        Hallo INSTARWie löse ich das ganze mit einer zweiten Kamera? Ich habe für jede Kamera einen eigenen Flow erstellt.
        Kann ich irgendwo mitgeben, dass entweder Flow1 oder Flow2 ausgeführt wird?

        Wir haben hier ein Tutorial wie man mit URL Queries des Alarmservers in Node-RED arbeitet:

        https://wiki.instar.de/Erweitert/Ala...our_Smarthome/

        Genau so kann man auch in IFTTT im Body des Request Informationen mitgeben - z.B.:


        {
        "val": on,
        "camera": "front_door"
        }


        Und dann in Node-RED nicht nur nach on/off sortieren, sondern auch nach der Kamera die man ansprechen möchte - im Beispiel die Kamera an der Eingangstür.

        Kommentar


        • #49
          Danke INSTAR

          So offen würde ich das Node-Red sowieso nicht betreiben wollen
          Muss mir das mit der Authentifizierung nochmals anschauen.

          Ich habe jetzt nochmals Node-Red unter folgender Anleitung https://wiki.instar.de/Software/Linux/Node-RED/ neu installiert.
          Habe alle Befehle mit dem Nodeadmin ausgeführt. Nur bei dem Befehl erhalte ich die Rückmeldung dass das Verzeichnis nicht existiert.


          Wenn ich das geschafft habe, kommt dann die Einbindung der zweiten Kamera dran.
          Zuletzt geändert von Markus2806; 24.11.2019, 17:38.

          Kommentar


          • #50
            Die Anleitungen unter:

            https://wiki.instar.de/Software/Linux/

            sind mehr ein Step-by-Step um Debian zu einer Smarthome Überwachungstation zu machen und bauen aufeinander auf. Ich denke das einfach der Benutzer nodeadmin auf dem System fehlt. In dem Fall liegt das Node-RED Verzeichnis im home Verzeichnis des Nutzers, den man während der Installation aktiv hatte. Um rauszufinden wo es ist, einfach mal das folgende eingeben:

            Code:
            cd ~
            ls -la
            Der erste Befehl bringt einen in das home Verzeichnis des aktiven Users, der zweite listet alle Dateien und Ordner in dem Verzeichnis. Wenn .node-red darunter ist:

            Code:
            cd ./.node-red
            pwd

            Mit dem ersten Befehl betritt man das Verzeichnis und der zweite zeigt einem den Pfad an, wo man sich gerade befinden - z.B. /home/meinnutzer/.node-red. Dann kann man den Befehl entsprechend ändern:


            Kommentar


            • #51
              Danke hat gekappt Komischerweise war der Pfad aber richtig
              Habe nun ein SSL Zertifikat erstellt und unter Common Name habe ich die lokale IP Adresse angegeben.
              Den Pfad habe ich in settings.js angepasst aber leider klappt es nicht mit dem Admin-Panel über https://<IP-Adresse>:1880/admin/ -> ERR_SSL_PROTOCOL_ERROR


              Kommentar

              Lädt...
              X