Ankündigung

Einklappen
Keine Ankündigung bisher.

Node-RED und IFTTT

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #16
    Den API-Key muss ich mir ja über https://ifttt.com/services/maker_webhooks/settings holen
    Das ist aber nicht der Key, den ich vorhin gepostet hatte. Der wird nämlich im Node-Red selbst generiert wenn ich im ifttt-key Node bearbeiten auf Akualisieren klicke.

    Wo trage ich dann den API-Key vom Ifttt Webhook ein?

    Ha, ich habs! Natürlich muss der Webhook Key in den Eigenschaften vom Ifttt Out Node eingetragen werden und nicht generiert werden, so wie ich es gemacht hab!

    Durch deine Hilfe bin ich nun ein großes Stück weiter gekommen, danke!
    Leider bekomme ich jetzt beim Ausführen keine Debug Meldung so wie im Wiki.
    Zuletzt geändert von Markus2806; 01.11.2019, 20:21.

    Kommentar


    • #17
      Wofür dann die automatische Generierung benutzt wird, bleibt ein Rätsel. Aber klar, da muss der eigene Key rein. Deshalb mein Vorschlag, den Key im Forum unkenntlich zu machen. Nachher schickt Dir wer anders ständig Trigger an Dein IFTTT, damit Du wahnsinnig wirst.

      Kommentar


      • #18
        Du musst eine Message Payload angeben. Die sollte dann bei korrektem Ablauf im Debugfenster ausgegeben werden. Denke ich. Trockenübung...

        Kommentar


        • #19
          Ja habe gerade gesehen, dass beim Code im Wiki noch ein json Node mit der Eigenschaft msg.payload sitzt.
          Auf den Bildern ist davon aber nichts zu sehen.
          Komisch ist aber auch, dass der Webhook - "If Maker Event "ifttt_webhook" then make a web request - gar nicht ausgeführt wird.

          Kommentar


          • #20
            Ein Debug-Node muss am Ende stehen, damit die Message Payload den von Dir erstellten Text im Debugfenster ausgeben kann.

            Kommentar


            • #21
              Tut es doch.

              debug_node.jpg

              Kommentar


              • #22
                Ich glaub das Problem liegt woanders: "Unable to make a web request. Your server returned a 404"
                Über extern komme ich aber über https://dnsname.dnsprovider.net : portnummer auf die Kamera

                Im Browser https://dnsname.dnsprovider.net : portnummer /pushalarm/trigger/recording bekomme ich

                Error 404: Not Found
                File not found.

                Ok so wie es aussieht ist dieser Pfad für den Alarmserver, den ich aber nicht aktiviert habe.
                Zuletzt geändert von Markus2806; 01.11.2019, 21:22.

                Kommentar


                • #23
                  Bei Fehler 404 kann die Webadresse nicht erreicht werden. Wenn Du im internen Netzwerk mit Deinem Browser bist, in dem auch die Kamera hängt, braucht man zumindest nicht mehr die WAN-Adresse, für die der DDNS-Name steht. Probier es stattdessen mit der internen IP-Adresse inkl. Port.

                  Kommentar


                  • #24
                    Das ist schon klar, nur der Webhook Service greift doch generell von außerhalb zu.
                    Denke es ist wirklich eher der deaktivierte Alarmserver.
                    Werde jetzt aber mal den Punkt "Deaktivieren des Alarms wenn man nach Hause kommt" ansehen, der für mich sowieso mehr Relevanz hat.


                    Kommentar


                    • #25
                      Stimmt, Du testest ja die Funktionen über den IFTTT-Service und nicht vom Browser direkt.

                      Kommentar


                      • #26
                        Ich habe jetzt mal das /pushalarm/trigger/recording durch /alarm/md/areas ersetzt.
                        Aber auch hier bekomme ich den 404 Error.

                        Kommentar


                        • #27
                          Wenn die Kamera von aussen konfiguriert werden soll (hier: Abschalten des Bewegungsalarms), dann muss es über CGI-Befehle gehen. In Deinem Beispiel sehe ich keinen Befehl, eher das Anspringen eines Verzeichnisses. Schau mal im Wiki bei den entsprechenden Kommandos nach.

                          Kommentar


                          • #28
                            Ja stimmt. So wie ich es verstanden habe sende ich mit IFTTT einen Befehl an Node-Red und dieser wiederum wendet die CGI-Befehle intern an die Kamera an. Dann muss ich sowieso diesen Flow hier verwenden, obwohl der wieder anders aussieht als im Wiki:

                            Anmerkung 2019-11-01 215933.jpg

                            Einen Inject-Trigger brauche ich ja jetzt nicht mehr, da das ganze sowieso dann ausgelöst werden soll wenn ich einen Bereich betrete oder verlasse.
                            Aber auch hier brauche ich doch den API-Key damit man weiß dass der Web Request von mir kommt. Einen Event Namen gibt es hier ja nicht mehr.
                            Ich betrete z.b einen Bereich, dann wird ein Web Request gemacht, nur was passiert dann?

                            Ich habe außerdem gerade bemerkt, dass ich den Port der Kamera und nicht vom Node-Red-Server genommen habe
                            Jetzt erklärt sich auch der 404 Fehler. Wenn ich jetzt auf ..../alarm/md/areas gehe komme ich zu einer Anmeldung.
                            Nur welche Daten muss ich hier eintragen? Sind das nicht die Log-in Daten vom Node-Red?

                            Die GCI-Befehle befinden sich in der Function-Node (z.b Enable Area 1):

                            function_node.jpg
                            Zuletzt geändert von Markus2806; 02.11.2019, 23:11.

                            Kommentar


                            • #29
                              Ich habe jetzt mal testweise statt dem "IFTTT Trigger" einen "Inject Trigger" gesetzt um das ganze auszuprobieren:

                              Anmerkung 2019-11-02 193404.jpg


                              Und es funktioniert
                              Jetzt muss es nur noch mit dem "IFTTT-Trigger" funktionieren und ich bin glücklich

                              Ich habe das ganze mit einem "Push Button" IFTTT Befehl probiert:

                              mit https://xxx.xxx.net:yyyy/alarm/md/areas bekomme ich "Unable to make web request: Error: write EPROTO xxx:error:xxxFC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:../deps/openssl/openssl/ssl/s..." zurück

                              mit http://xxx.xxx.net:yyyy/alarm/md/areas bekomme ich "Unable to make web request. Your server returned a 401" zurück
                              Im Browser komme ich hier auch zu einem Anmeldefenster. Denke auch das es auch deshalb scheitert. Nur welche Anmeldedaten sind das?
                              Bzw. wo gebe ich diese Daten mit?



                              Angehängte Dateien
                              Zuletzt geändert von Markus2806; 02.11.2019, 22:38.

                              Kommentar


                              • #30
                                Anmeldedaten beziehen sich vielleicht auf den Admin-Account der Kamera, um Änderungen an den Einstellungen vornehmen zu können. Du kannst doch statt dem ganzen Node-Red Gedönse auch direkt per Smartphone einen CGI-Command absetzen, damit die Alarme abgeschaltet werden?
                                Oder gleich die App von Instar nutzen.
                                Im Forum hatte mal jemand was dazu geschrieben, dass er bei Heimkehr nach Hause automatisiert (?) den Alarm abschalten lassen wollte und bei Verlassen des Hauses alles wieder scharf schalten wollte. Musst mal die Suchfunktion befragen. Ich kann mich nur nicht erinnern, ob das mit Node-Red gemacht wurde.

                                Kommentar

                                Lädt...
                                X